.content-image-wrapper .graf-figure {display: none;} border=0

Ubuntu 20.04 LTS вроде 19.10, с частичной поддержкой 32-битного кода

дома новости
Революции не будет, фото Canonical

Об авторе

Ubuntu 20.04 LTS будет иметь 32-битные пакеты, но только некоторые, в точности как выпуск 19.10, - рассказал Стив Лангасек , программист Canonical. Как вы видите, после дыма, связанного с отмененной идеей полного отказа от поддержки приложения i386, компания предпочитает быть в безопасности. И это неудивительно, потому что ответ был разрушительным в то время.

Как и в случае с 19.10, насыщенность Ubuntu 20.04 LTS 32-битными библиотеками должна быть ограничена. Canonical хочет оставить только те пакеты, которые необходимы для совместимости с ключевыми программами и устройствами. Тем не менее, он сообщает, что их список будет немного отличаться от сегодняшнего, хотя он по-прежнему включает около 1,7 тысячи. пакеты.

Как мы читаем, было принято решение удалить, среди прочего libssl1.0, wine-stable-i386 и gcc-8-base. По словам Лангасека, решающим фактором была общая архаичность и широкое использование 64-битных эквивалентов. С другой стороны, даже 32-разрядные драйверы VDPAU и VA-API вернутся к Ubuntu 20.04 LTS, что крайне важно для получения аппаратного ускорения в браузере на компьютерах с более старой видеокартой.

В настоящее время, как сообщается, проводится перекрестное тестирование дополнительных библиотек на платформе amd64 (x86_64), но трудно ожидать какого-либо впечатляющего фиаско.

Вывод, однако, заключается в том, что Ubuntu 20.04 LTS может легко работать с 32-битным программным обеспечением, включая, что, вероятно, важно для многих, клиент Steam и игры. Никто не ожидал, что все будет иначе, но формальности выполнены.

© хорошие программы